Задать вопрос
31 января, 04:35

Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и четные, и нечетные элементы).

+5
Ответы (1)
  1. 31 января, 07:35
    0
    Var i, maxk, maxd, r:integer;

    a:array[1 ... 30] of integer;

    begin

    for i:=1 to 30 do

    a[i]:=random (100) ;

    maxk:=0;

    maxd:=0;

    for i:=1 to 30 do

    begin

    if (a[i] mod 2 = 0) and (a[i]>maxk) then maxk:=a[i];

    if (a[i] mod 2 0) and (a[i]>maxd) then maxd:=a[i];

    end;

    r:=maxk-maxd;

    writeln (r) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Решение есть. нужно его объяснить. Опишите на русском языке или на одном из языков программирования алгоритм вычисления разности максимального среди элементов, имеющих четные значения, и максимального среди элементов имеющих нечетные значения, в
Ответы (1)
В заданном массиве a от n целых элементов, все нечетные по значению элементы удвоить, а чётные увеличить на 1. Все четные элементы по номеру возвести в квадрат
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)