Задать вопрос
17 мая, 20:56

В заданном массиве a от n целых элементов, все нечетные по значению элементы удвоить, а чётные увеличить на 1.

Все четные элементы по номеру возвести в квадрат

+5
Ответы (1)
  1. 18 мая, 00:19
    0
    var n, i:longint;

    var a:array[1 ... 10000000] of longint;

    begin

    writeln ('Введите количество элементов массива') ;

    readln (n) ;

    writeln ('Введите все элементы массива через пробел') ;

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n do if (a[i] mod 2 = 0) then a[i]:=a[i]+1 else if a[i] mod 2 0 then a[i]:=a[i]*2;

    for i:=1 to n do if i mod 2 = 0 then a[i]:=sqr (a[i]) ;

    for i:=1 to n do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В заданном массиве a от n целых элементов, все нечетные по значению элементы удвоить, а чётные увеличить на 1. Все четные элементы по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)