Задать вопрос
14 ноября, 05:13

Это программирование, паскаль, нужно написать программу

Дан одномерный массив A, состоящий из N элементов, N - заданное натуральное

число. Если элементы массива составляют строго монотонную последовательность, то

все положительные элементы массива заменить единицей, иначе оставить массив без

изменения.

+5
Ответы (1)
  1. 14 ноября, 05:29
    0
    A:array[1 ... 30000] of integer;

    n, i, k, z:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ;

    for i:=1 to n do

    if (a[i]
    for i:=1 to n do

    if (a[i]>a[i+1]) then z:=z+1;

    if (k=n) or (z=n) then

    for i:=1 to n do

    if a[i]>0 then a[i]:=1;

    for i:=1 to n do

    writeln (a[i]) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Это программирование, паскаль, нужно написать программу Дан одномерный массив A, состоящий из N элементов, N - заданное натуральное число. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)