Задать вопрос
17 декабря, 13:12

Составить программу.

Дано натуральное число n. Подсчитать количество цифр этого числа.

+5
Ответы (2)
  1. 17 декабря, 13:28
    0
    Var

    n: longint;

    s: string;

    k: byte;

    begin

    Write ('Введите натуральное число ') ; Readln (n) ;

    { Преобразуем число к строке, убрав знак (мало ли ...) }

    Str (abs (n), s) ;

    { Выведем длину полученной строки }

    Writeln ('Количество цифр в числе равно ', Length (s))

    end.

    Тестовое решение:

    Введите натуральное число 164275353

    Количество цифр в числе равно 9
  2. 17 декабря, 13:52
    0
    Program chisla;

    uses crt;

    var a, b, c: integer;

    begin

    writeln ('Введите натуральное число: ') ;

    readln (a) ;

    b:=a;

    c:=0;

    while b 0 do

    begin

    c:=c+1;

    b: = b div 10;

    end;

    writeln ('B числе ', a,' - ', c, ' цифр') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу. Дано натуральное число n. Подсчитать количество цифр этого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)