Задать вопрос
17 декабря, 04:05

Составьте программу замены в слове, введенном с клавиатуры, всех букв"и" на"а"и"а"на"о". сосчитать количество замен. отладка программы для слова"накидка"

+4
Ответы (1)
  1. 17 декабря, 05:38
    0
    Program Stroka;

    Uses Crt;

    var a:string;

    c1, c2, i, k:integer;

    begin

    clrscr;

    write ('Введите строку: ') ;

    readln (a) ;

    k:=length (a) ;

    c1:=0; c2:=0;

    / / Первый проход меняем "и" на "a"

    for i:=1 to k do if (a[i]='и') or (a[i]='И') then

    begin

    a[i]:='а';

    c1:=c1+1;

    end;

    / / Второй проход меняем "а" на "о"

    for i:=1 to k do if (a[i]='а') or (a[i]='А') then

    begin

    a[i]:='о';

    c2:=c2+1;

    end;

    writeln;

    writeln ('Строка после всех замен:', a) ;

    writeln ('Замен и на а:', c1) ;

    writeln ('Замен a на о:', c2) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу замены в слове, введенном с клавиатуры, всех букв"и" на"а"и"а"на"о". сосчитать количество замен. отладка программы для ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Этапы создания программы: Построение алгоритма, составление программы, отладка программы, постановка задачи, построение математической модели решения задачи, формальное построение модели задачи. Соотнесите по порядку
Ответы (1)
Нужно подробное написание программы в pascalABC 1) С клавиатуры вводится число в интервале от 1 до 999. Написать программу, которая определяет количество цифр во введенном числе.
Ответы (1)
Составить подпрограмму, заменяющую все элементы одномерного массива, меньшие заданной величины Т, на значение этой величины и считающую число таких замен.
Ответы (1)
С клавиатуры вводится текст. Посчитать сколько букв "е" в слове введённом с клавиатуры.
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)