Задать вопрос
30 августа, 12:25

Составьте программу, вычисляющую для двух дробей a/b и c/d (a, b, c, d - натуральные числа) :

деление

умножение

сложение.

Результат представить в виде простых несократимых дробей

В виде функции.

Pascal

+3
Ответы (1)
  1. 30 августа, 12:33
    0
    Как-то так)

    var a, b, c, d, e, f:integer;

    function nod (m, n:integer) : integer;

    begin

    while mn do

    if m>n then m:=m-n

    else n:=n-m;

    nod:=m

    end;

    begin

    write ('введите числитель1, знаменатель1, числитель2, знаменатель2') ;

    readln (a, b, c, d) ;

    e:=a*d+b*c;

    f:=b*d;

    if f=0 then write ('на 0 делить нельзя')

    else

    if e=0 then writeln ('сложение = ', e)

    else begin

    e:=e div nod (abs (e), f) ;

    f:=f div nod (abs (e), f) ;

    writeln ('сложение = ', e,'/', f) ;

    end;

    e:=a*c;

    f:=b*d;

    if f=0 then write ('на 0 делить нельзя')

    else

    if e=0 then writeln ('умножение = ', e)

    else begin

    e:=e div nod (abs (e), f) ;

    f:=f div nod (abs (e), f) ;

    writeln ('умножение = ', e,'/', f) ;

    end;

    e:=a*d;

    f:=b*c;

    if f=0 then write ('на 0 делить нельзя')

    else

    if e=0 then writeln ('деление = ', e)

    else begin e:=e div nod (abs (e), f) ;

    f:=f div nod (abs (e), f) ;

    writeln ('деление = ', e,'/', f) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, вычисляющую для двух дробей a/b и c/d (a, b, c, d - натуральные числа) : деление умножение сложение. Результат ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин
Ответы (1)