Задать вопрос
9 сентября, 13:02

Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую периметр треугольника по координатам его вершин

+4
Ответы (1)
  1. 9 сентября, 14:44
    0
    Function leng (var x, y, x1, y1: real) : real;

    begin

    leng:=sqrt (sqr (x-x1) + sqr (y-y1)) ;

    end;

    / / основная программа

    var x1, y1, x2, y2, x3, y3, p: real;

    begin

    write ('координаты вершин x1 y1 x2 y2 x3 y3 через пробел: ') ;

    readln (x1, y1, x2, y2, x3, y3) ;

    if (leng (x2, y2, x1, y1) + leng (x3, y3, x2, y2) = leng (x3, y3, x1, y1)) or

    (leng (x2, y2, x1, y1) + leng (x3, y3, x1, y1) = leng (x3, y3, x2, y2)) or

    (leng (x3, y3, x2, y2) + leng (x3, y3, x1, y1) = leng (x2, y2, x1, y1)) then

    writeln ('точки лежат на одной прямой')

    else

    begin

    p:=leng (x2, y2, x1, y1) + leng (x3, y3, x2, y2) + leng (x3, y3, x1, y1) ;

    writeln ('периметр: ', p:7:3) ;

    end;

    end.

    координаты вершин x1 y1 x2 y2 x3 y3 через пробел: 3 4 7 2 6 5

    периметр: 10.797

    координаты вершин x1 y1 x2 y2 x3 y3 через пробел: 1 2 3 4 5 6

    точки лежат на одной прямой
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите функцию, вычисляющую длину отрезка по координатам его концов. С помощью этой функции напишите программу на Pascal ABC, вычисляющую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)