Задать вопрос
7 февраля, 16:17

1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет.

2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр.

3. Составьте программу в Pascal ABC. Дано двузначное число. Вывести число, полученное при перестановке цифр.

+4
Ответы (1)
  1. 7 февраля, 19:03
    0
    1.

    var a: real;

    x, y: integer;

    begin

    readln (x, a, y) ;

    writeln ('1 kg konfet stoit ', a/x:1:2) ;

    writeln (y,' kg konfet stoyat ', a/x*y:1:2) ;

    readln;

    end.

    2.

    var a, s, p: integer;

    begin

    readln (a) ;

    s:=a mod 10 + a div 10;

    p: = (a mod 10) * (a div 10) ;

    writeln (s) ;

    writeln (p) ;

    readln;

    end.

    3.

    var a, b: integer;

    begin

    readln (a) ;

    b: = (a mod 10) * 10 + (a div 10) ;

    writeln (b) ;

    readln;

    end.

    Это если без циклов.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести число, полученное при перестановке крайних чисел исходного числа
Ответы (1)