Задать вопрос
25 марта, 20:33

Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево.

2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число.

3) Дано трехзначное число. Найти число, полученное при перестановке первой и второй цифр заданного числа.

+3
Ответы (1)
  1. 25 марта, 22:30
    0
    Var

    n, n1, n2, n3: integer;

    begin

    write ('Введите трехзначное число: ') ;

    readln (n) ;

    if not ((n > = 100) and (n < = 999)) then writeln ('Не верный вводд числа')

    else

    begin

    n1 : = n div 100;

    n2 : = n div 10 mod 10;

    n3 : = n mod 10;

    writeln ('1 - ', n3, n2, n1) ;

    writeln ('2 - ', n3, n1, n2) ;

    writeln ('3 - ', n2, n1, n3) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)
Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число.
Ответы (2)
Написать программу на Паскале: Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти это число.
Ответы (1)
Задача по программированию 8 класс. Решите как положено через паскаль! Дано трехзначное число. Найти число, полученное при перестановке первой и второй цифр заданного числа
Ответы (1)