Задать вопрос
2 августа, 18:21

Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести число, полученное при перестановке крайних чисел исходного числа

+5
Ответы (1)
  1. 2 августа, 20:56
    0
    Program z1;

    var x:integer;

    a1, a2, a3:integer;

    begin

    write ('x=') ; readln (x) ;

    a1:=x div 100;

    a2: = (x div 10) mod 10;

    a3:=x mod 10;

    x:=a3*100+a2*10+a1;

    writeln (x) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести число, полученное при перестановке крайних ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите, с помощью паскаля надо сделать следующее: Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составьте программу для Pascal abc, решающую следующую задачу. У продавца имеются гири весом 1, 2, 5 кг. Наберите минимальное кол-во гирь для взвешивания N кг.
Ответы (1)