Задать вопрос
27 марта, 04:10

Составьте программу для Pascal abc, решающую следующую задачу. У продавца имеются гири весом 1, 2, 5 кг. Наберите минимальное кол-во гирь для взвешивания N кг.

+4
Ответы (1)
  1. 27 марта, 07:49
    0
    Program z1;

    var n:integer;

    s1, s2, s5:integer;

    begin

    write ('n=') ; readln (n) ;

    s5:=n div 5; n:=n mod 5;

    s2:=n div 2; s1:=n mod 2;

    writeln ('5 kg-', s5,'; 2 kg-', s2,'; 1 kg-', s1) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу для Pascal abc, решающую следующую задачу. У продавца имеются гири весом 1, 2, 5 кг. Наберите минимальное кол-во гирь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите в Паскаль ABC Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в N рублей так, чтобы она состояла из минимального количества монет.
Ответы (1)
Помогите, с помощью паскаля надо сделать следующее: Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Написать программу для Pascal Abc, решающую следующую задачу: дано трёхзначное число. Вывести число, полученное при перестановке крайних чисел исходного числа
Ответы (1)