Задать вопрос
4 марта, 03:34

Решите в Паскаль ABC

Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас

имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в

N рублей так, чтобы она состояла из минимального

количества монет.

+5
Ответы (1)
  1. 4 марта, 05:04
    0
    Var a: integer;

    begin

    readln (a) ;

    writeln (a div 10, 'x10, ', a mod 10 div 5, 'x5, ', a mod 10 mod 5 div 2, 'x2, ', a mod 50 mod 5 mod 2 div 1, 'x1') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решите в Паскаль ABC Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются монеты номиналом 1, 2, 5, 10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике