Задать вопрос
23 февраля, 07:03

Дан одномерный массив, который содержит не более 10 целых чисел. Найти среднее арифметическое элементов, которые стоят на нечетных местах.

+2
Ответы (1)
  1. 23 февраля, 10:39
    0
    uses crt;

    var

    i, k: integer;

    a, k2: real;

    mas, ma: array [1 ... 10] of integer;

    begin

    randomize;

    write (' razmer massiva = ') ; readln (k) ;

    for i:=1 to k do

    mas[i]: = random (10) ;

    for i:=1 to k do

    write (mas[i],' ') ;

    for i:=1 to k do

    if i mod 20 then a: = mas[i]+a;

    writeln;

    if k mod 2 0 then begin k:=k+1; k2: = k/2; end else k2: = k/2;

    a: = a/k2;

    write ('sredn znach = ', a) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив, который содержит не более 10 целых чисел. Найти среднее арифметическое элементов, которые стоят на нечетных местах. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)