Задать вопрос
25 марта, 05:07

Программирование логических выражений.

Написать программу в Паскале.

Данное четырёхзначное число читается одинаково слева направо и справа налево.

+5
Ответы (1)
  1. 25 марта, 07:41
    0
    Var a, b, c:integer;

    begin

    read (a) ;

    b:=a mod 100;

    a:=a div 100;

    c:=b div 10;

    b:=b mod 10;

    b:=b*10+c;

    if a=b then write ('true') ;

    if ab then write ('false') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование логических выражений. Написать программу в Паскале. Данное четырёхзначное число читается одинаково слева направо и справа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
Помогите написать программу на паскале абс Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково.
Ответы (1)
При выполнении какого из перечисленных ниже алгоритмов на экране появился правильный треугольник? 1 Повтори 3 [Вперёд 50 Направо 20 Направо 25] 2 Повтори 3 [Вперёд 50 Направо 100 Направо 20] 3 Повтори 6 [Вперёд 50 Направо 10 Направо 20] 4 Повтори 6
Ответы (1)
Дано натуральное число. Выяснить, является ли оно палиндромом ("перевертышем"), т. е. числом, десятичная запись которого читается одинаково слева направо и справа налево. Помогите написать на паскале
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)