Задать вопрос
15 июня, 11:12

Помогите написать программу на паскале абс

Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково. Иначе говоря, отличается симметрией записи (расположения цифр), причём число знаков может быть как чётным, так и нечётным. Например, 165 его палиндром 561.

+2
Ответы (1)
  1. 15 июня, 14:27
    0
    Program palidron;

    var

    a, b, c, x, d: integer;

    begin

    writeln ('Число:') ;

    readln (a) ;

    b: = a mod 10;

    c: = ((a div 10) mod 10) ;

    x: = ((a div 10) div 10) ;

    d: = 100*b+10*c+x;

    writeln ('Палиндром: ', b, c, x) ;

    writeln ('Произведение числа и палиндрома: ', d*a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале абс Дано трехзначное число. Найдите его палиндром и произведение палиндрома и данного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано двузначное число. Найдите его палиндром и произведение палиндрома и данного числа. Числовой палиндром - это натуральное число, которое читается слева направо и справа налево одинаково.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)
Найдите самый большой палиндром (натуральное число, одинаково читающееся как слева направо, так и справа налево), который является произведением трехзначного и четырехзначного числа. В качестве ответа укажите одно натуральное число, например, 111.
Ответы (1)
Найдите самый большой палиндром (натуральное число, одинаково читающееся как слева направо, так и справа налево), который является произведением двух четырехзначных чисел. В качестве ответа укажите одно натуральное число, например, 111.
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)