Задать вопрос
21 ноября, 00:45

Написать программу на языке Pascal

Палиндромом называется строка, которая одинаково читается как слева направо, так и

справа налево. Рассмотрим все натуральные числа, запись которых в десятичной системе

счисления является палиндромом (при этом запись не начинается с нуля). Например, числа

121 и 1331 являются палиндромами, а число 123 - нет. По данному числу N найдите N-e в

порядке возрастания число-палиндром.

Программа получает на вход одно натуральное число N, не превосходящее 100 000.

Программа должна вывести одно натуральное число - N-е в порядке возрастания

число-палиндром.

Пример входных и выходных данных

Ввод 20

Вывод 111

+2
Ответы (1)
  1. 21 ноября, 03:38
    0
    Var

    s: string;

    n, m: integer;

    begin

    readln (n) ;

    if (n < = 9) then write (n)

    else if (n < = 9 + 9) then

    begin

    s : = inttostr (n - 9) ;

    write (s + s) ;

    end

    else if (n < = 9 + 9 + 90) then

    begin

    s : = inttostr (n - 9 - 9 + 10 - 1) ;

    m:=s. Length-1;

    write (s + s[m:0:-1]) ;

    end

    else if (n < = 9 + 9 + 90 + 90) then

    begin

    s : = inttostr (n - 9 - 9 + 90 + 10 - 1) ;

    write (s + s[::-1]) ;

    end

    else if (n < = 9 + 9 + 90 + 90 + 900) then

    begin

    s : = inttostr (n - 9 - 9 - 90 - 90 + 100 - 1) ;

    m:=s. Length-1;

    write (s + s[m:0:-1]) ;

    end

    else if (n < = 9 + 9 + 90 + 90 + 900 + 900) then

    begin

    s : = inttostr (n - 9 - 9 - 90 - 90 - 900 + 100 - 1) ;

    write (s + s[::-1]) ;

    end

    else if (n < = 9 + 9 + 90 + 90 + 900 + 900 + 9000) then

    begin

    s : = inttostr (n - 9 - 9 - 90 - 90 - 900 - 900 + 1000 - 1) ;

    m:=s. Length-1;

    write (s + s[m:0:-1]) ;

    end

    else if (n < = 9 + 9 + 90 + 90 + 900 + 900 + 9000 + 9000) then

    begin

    s : = inttostr (n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 + 1000 - 1) ;

    write (s + s[::-1]) ;

    end

    else

    begin

    s : = inttostr (n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 - 9000 + 10000 - 1) ;

    m:=s. Length-1;

    write (s + s[m:0:-1]) ;

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача F Четный палиндром Подстрокой строки называется любая непустая последовательность символов в строке. Палиндромом называется строка, которая читается одинаково слева и справа. У Азизхана есть строка S.
Ответы (1)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
1. На вход программе даётся число N и N чисел (все натуральные 24; 5 13 4 16 100 8 = > 4 2.
Ответы (1)