Задать вопрос
8 мая, 22:48

1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением. выведите на экран исходный и измененный массивы

2) Составьте программу формирования и вывода на экран одномерного массива, состоящего из минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

+5
Ответы (1)
  1. 9 мая, 00:08
    0
    1)

    var a:array[1 ... 5,1 ... 5] of integer;

    i, j, max:integer;

    begin

    randomize;

    max:=0;

    for i:=1 to 5 do

    for j:=1 to 5 do begin

    a[i, j]:=random (100) ;

    if a[i, j]>max then max:=a[i, j];

    end;

    for i:=1 to 5 do begin

    writeln;

    for j:=1 to 5 do

    write (a[i, j],' ') ;

    end;

    writeln;

    writeln;

    writeln;

    for i:=1 to 5 do

    for j:=1 to 5 do

    if j=5 then a[i, j]:=max;

    for i:=1 to 5 do begin

    writeln;

    for j:=1 to 5 do

    write (a[i, j],' ') ;

    end;

    end.

    2-ую лень. Дико извиняюсь.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали двумерного массива, заданного с помощью датчика случайных чисел. (Паскаль абс) С объяснением.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Составьте программу формирования и вывода на экран одномерного массива, состоящего из количества положительных элементов строк двумерного массива.
Ответы (1)
Помогите решить. Напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки.
Ответы (1)