Задать вопрос
26 июля, 08:49

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое.

2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

+5
Ответы (1)
  1. 26 июля, 11:37
    0
    1. program z;

    var a:array [1 ... 10] of integer; i, t:integer; s:real;

    begin

    for i:=1 to 10 do

    begin

    a[i]:=random (1,100) ;

    write (a[i]:4) ;

    if (odd (i)) and (odd (a[i])) then

    begin

    s:=s+a[i];

    t:=t+1;

    end;

    end;

    writeln;

    write ('Cреднее арифметическое = ', s/t) ;

    end.

    2. program z;

    var a:array[1 ... 10] of integer; max, i:integer;

    begin

    writeln ('Исходный массив') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (1,100) ;

    write (a[i]:4) ;

    if a[i]>max then max:=a[i];

    end;

    writeln;

    writeln ('Измененный массив') ;

    for i:=1 to 10 do

    begin

    if not (odd (a[i])) then a[i]:=max;

    write (a[i]:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с информатикой, ту массивы на языке Паскаль. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените нулем элементы массива, которые больше введенного с клавиатуры числа N. Выведите на экран исходный и полученный массивы
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Дан массив С (10). Сформируйте из него массивы А (5) и В (5), предварительно определив их длину. В массив А включите элементы из массива С с четными индексами, а в В - с нечетными. Выведите на экран массивы А (5), В (5) и С (10).
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)