Задать вопрос
22 сентября, 04:48

Помогите с информатикой, ту массивы на языке Паскаль. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените нулем элементы массива, которые больше введенного с клавиатуры числа N. Выведите на экран исходный и полученный массивы

+3
Ответы (1)
  1. 22 сентября, 08:44
    0
    Var a, n:integer; m:array [1 ... 10] of integer;

    begin

    readln (n) ;

    for a:=1 to 10 do

    begin

    m[a]:=random (50) ;

    writeln (m[a]) ;

    end;

    writeln ('новый массив') ;

    for a:=1 to 10 do

    begin

    If m[a]>n then m[a]:=0;

    writeln (m[a]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с информатикой, ту массивы на языке Паскаль. Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените нулем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все отрицательные элементы на наименьший положительный. Выведите на экран исходный и полученный массив.
Ответы (1)