Задать вопрос
11 февраля, 18:50

Дан массив С (10). Сформируйте из него массивы А (5) и В (5), предварительно определив их длину. В массив А включите элементы из массива С с четными индексами, а в В - с нечетными. Выведите на экран массивы А (5), В (5) и С (10).

+4
Ответы (1)
  1. 11 февраля, 21:23
    0
    Const n=10; m=5;

    var

    i, j, k:integer;

    A:array[1 ... n] of integer;

    B, C:array[1 ... m] of integer;

    begin

    writeln ('Введите элкменты массива') ;

    for i:=1 to n do readln (a[i]) ;

    j:=0; k:=0;

    for i:=1 to n do

    if i mod 2=1 then begin j:=j+1; B[j]:=A[i] end

    else begin k:=k+1; C[k]:=A[i] end;

    writeln ('Массив А') ;

    for i:=1 to n do write (A[i],' ') ;

    writeln;

    writeln ('Массив B') ;

    for i:=1 to j do write (B[i],' ') ;

    writeln;

    writeln ('Массив C') ;

    for i:=1 to k do write (C[i],' ') ;

    writeln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив С (10). Сформируйте из него массивы А (5) и В (5), предварительно определив их длину. В массив А включите элементы из массива С ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данных Сначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Даны два массива: А (10) и В (10). Сформируйте массив С (10), предварительно определив его длину, включая из массивов А и В только четные по номеру элементы. Вы ведите на экран массивы А (10), В (10) и С (10).
Ответы (1)