Задать вопрос
15 июля, 21:46

Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.

+3
Ответы (1)
  1. 16 июля, 01:38
    0
    Помоему так ...

    const n=10;

    var a:array[1 ... n] of integer; i, k:integer;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to n do begin

    a[i]:=random (10) ;

    write (' ', a[i]) ;

    end;

    writeln;

    for i:=1 to n do begin

    if ((i mod 2) = 0) then

    a[i]:=a[i]*2

    else

    a[i]:=a[i]*3;

    end;

    writeln ('Конечный массив: ') ;

    for i:=1 to n do

    write (' ', a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)