Задать вопрос
7 февраля, 08:13

1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с нечётными значениями в три раза, а элементы с чётными значениями заменяя на 0.

+1
Ответы (1)
  1. 7 февраля, 11:20
    0
    1) var a:array [1 ... 10] of integer;

    i:integer;

    begin

    for i:=1 to 10 do

    read (a[i]) ;

    for i:=1 to 10 do

    begin

    if a[i] mod 2 = 0 then

    a[i]:=a[i]+1;

    writeln (a[i]) ;

    end;

    end.

    2)

    var a:array [1 ... 10] of integer;

    i:integer;

    begin

    for i:=1 to 10 do

    read (a[i]) ;

    for i:=1 to 10 do

    if (a[i]+1) mod 2 = 0 then

    begin

    a[i]:=a[i]*3;

    writeln (a[i]) ;

    end

    else

    begin

    if a[i] mod 2 = 0 then

    writeln (0) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Cоставьте программу, которая заполняет массив а [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с нечётными значениями в три раза, а элементы с чётными значениями заменяя на 0.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
А) Составьте программу, которая заполняет массив В[1 ... 11] случайными целыми числами в диапазоне от - 5 до 5 и преобразовывает его, заменяя элементы кратные 5 на 5, а остальные увеличивая в 5 раз.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)