Задать вопрос
31 октября, 05:48

A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.

б) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. Выведите на экран исходный и полученный массивы.

Программы должны выводиться в Строчку. (write)

+5
Ответы (1)
  1. 31 октября, 07:46
    0
    Var

    i, x:integer;

    m:array[10 ... 20] of integer;

    begin

    randomize;

    for i:=10 to 20 do m[i]:=random (11) + 10;

    for i:=10 to 20 do write (m[i],' ') ;

    writeln;

    x:=m[10];

    m[10]:=m[20];

    m[20]:=x;

    for i:=10 to 20 do write (m[i],' ') ;

    writeln;

    end.

    2)

    var

    max, min, i, x:integer;

    m:array[10 ... 20] of integer;

    begin

    min:=10;

    max:=10;

    randomize;

    for i:=10 to 20 do m[i]:=random (100) + 1;

    for i:=10 to 20 do write (m[i],' ') ;

    writeln;

    for i:=10 to 20 do begin if m[i]
    if m[i]>m[max] then max:=i;

    end;

    x:=m[min];

    m[min]:=m[max];

    m[max]:=x;

    for i:=10 to 20 do write (m[i],' ') ;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая заполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученый массивы
Ответы (2)
сотсавьте программу которая заполнит массив a[1 ... 10] случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. Выведите на экран исходный и полученный массивы ... это в паскале
Ответы (1)
Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Помогите все в паскале соствьте программу которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Введите на экран исходный и полученный массивы
Ответы (1)