Задать вопрос
7 сентября, 10:38

Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.

+3
Ответы (1)
  1. 7 сентября, 12:45
    0
    Program Program1;

    Var

    a:array [1 ... 10] of integer;

    i, temp:integer;

    begin

    randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) + 1;

    writeln ('a[', i,']=', a[i]) ;

    end;

    temp:=a[1];

    a[1]:=a[10];

    a[10]:=temp;

    writeln;

    writeln ('Полученный массив:') ;

    for i:=1 to 10 do

    writeln ('a[', i,']=', a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Помогите все в паскале соствьте программу которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Введите на экран исходный и полученный массивы
Ответы (1)
Составьте программу, которая заполняет массив а (1 ... 10) случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. выведите на экран исходный и полученый массивы
Ответы (2)