Задать вопрос
12 августа, 13:35

Помогите все в паскале

соствьте программу которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Введите на экран исходный и полученный массивы

+1
Ответы (1)
  1. 12 августа, 13:59
    0
    program shegor2003;

    var a:array[1 ... 10] of integer;

    i, temp:integer;

    begin

    for i: = 1 to 10 do

    a[i]:=random (11) ;

    writeln ('Исходный массив:') ;

    for i: = 1 to 10 do

    write (a[i]:3, ' ') ;

    writeln;

    temp:=a[1];

    a[1]:=a[10];

    a[10]:=temp;

    writeln ('Преобразованный массив:') ;

    for i: = 1 to 10 do

    write (a[i]:3, ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите все в паскале соствьте программу которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Cоставьте программу, которая заполняет массив a [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с чётными значениями на 1.
Ответы (1)
Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
сотсавьте программу которая заполнит массив a[1 ... 10] случайными целыми числами в диапазоне от 1 до 100, затем меняет местами максимальный и минимальный элементы. Выведите на экран исходный и полученный массивы ... это в паскале
Ответы (1)