Задать вопрос
24 июля, 14:56

Задача на Паскале. Дано число, если оно кратно 3 (трем) - увеличить его на 5, если кратно 2 (двум) - увеличить в 4 раза, если не кратно - увеличить на 1. * Использовать функцию "остаток от деления равен нулю".

+3
Ответы (1)
  1. 24 июля, 17:21
    0
    Function f (a, b:integer) : boolean;

    begin

    f:=a mod b = 0;

    end;

    var n:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    if f (n, 3) then n:=n+5

    else if f (n, 2) then n:=n*4

    else n:=n+1;

    writeln ('n = ', n) ;

    end.

    Пример:

    n = 21

    n = 26
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача на Паскале. Дано число, если оно кратно 3 (трем) - увеличить его на 5, если кратно 2 (двум) - увеличить в 4 раза, если не кратно - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
14. Составить алгоритм и написать решение задачи на Паскале: Сгенерировано целое число от 50 до 70. Найти его квадрат, если оно кратно 2 и куб, если оно кратно 3.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Решить в паскале: дано двузначное число, определить: а) кратно ли 3 сумма его цифр; б) кратно ли сумма его цифр числу a
Ответы (1)
Написать программу в паскале: 1. Удвоить заданное число, если оно положительное, утроить его, если оно отрицательно, и увеличит его на 1, если оно равно нулю.
Ответы (1)