Задать вопрос
24 августа, 13:03

Написать программу в паскале: 1. Удвоить заданное число, если оно положительное, утроить его, если оно отрицательно, и увеличит его на 1, если оно равно нулю.

+3
Ответы (1)
  1. 24 августа, 14:42
    0
    Var a:real;

    begin

    readln (a) ;

    if a>0 then a:=a*2;

    if a<0 then a:=a*3;

    if a=0 then a:=a+1;

    writeln (a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале: 1. Удвоить заданное число, если оно положительное, утроить его, если оно отрицательно, и увеличит его на 1, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике