Задать вопрос
5 февраля, 23:46

Помогите решить. Напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел замените в нем значения элементов с четной суммой индексов на значение второго элемента массива из первой строки. Выведите на экран исходный и измененный массив. (Паскаль абс) С объяснением

+4
Ответы (1)
  1. 6 февраля, 03:24
    0
    Const

    n=5;

    var

    a:array[1 ... n, 1 ... n] of integer;

    i, j:integer;

    begin

    //генератор случайных чисел. Диапазон от 1 до 10.

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (10) + 1;

    write (a[i, j]," ") ;

    end;

    writeln () ;

    end;

    //Проверка условия и переприсвоение, если верно.

    for i:=1 to n do

    for j:=1 to n do

    begin

    if (((i+j) mod 2) = 0) then

    a[i, j]:=a[1,2];

    end;

    //Вывод полученного массива.

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    write (a[i, j]," ") ;

    end;

    writeln () ;

    end;

    //Ожидание.

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить. Напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел замените в нем значения элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)