Задать вопрос
28 февраля, 15:06

Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали двумерного массива, заданного с помощью датчика случайных чисел. (Паскаль абс) С объяснением.

+1
Ответы (1)
  1. 28 февраля, 17:23
    0
    Const

    n=5

    var

    a:array[1 ... n] of integer; / / создали одномерный массив длинной 5

    b:array[1 ... n, 1 ... n] of integer; / / создали двумерный массив 5 х5

    i, j:integer; / / i, j - счетчик

    begin

    for i:=1 to n do

    for j:=1 to n do

    b[i, j]:=random (10) + 1; {задали массив случайными числами в диапазоне от 1 до 10}

    for i:=1 to n do

    begin

    a[i]:=b[i, i]; / / присваиваем i-ому элементу массива элемент i-i.

    end; / / То есть 1-ому, 1-1, 2-ому 2-2. Это и есть главная диагональ.

    {вывод двумерного массива на всякий случай:

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    write (b[i, j],' ') ;

    end;

    writeln ("") ;

    end; }

    For i:=1 to n do

    write (a[i]," ") ;

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Составьте программу формирования и вывода на экран одномерного массива, состоящего из количества положительных элементов строк двумерного массива.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)