Задать вопрос
4 июля, 17:21

Составьте программу формирования и вывода на экран одномерного массива, состоящего из количества положительных элементов строк двумерного массива.

+3
Ответы (1)
  1. 4 июля, 20:01
    0
    Код Pascal:

    Const

    N = 3;

    M = 4;

    Var

    A:array[1 ... N, 1 ... M] of shortint;

    B:array[1 ... N] of byte;

    i, j, k:byte;

    Begin

    Randomize;

    For i: = 1 to N do

    Begin

    k:=0;

    For j: = 1 to M do

    Begin

    A[i, j]:=random (21) - 10;

    Write (A[i, j]:3,' ') ;

    if A[i, j] > 0 then k:=k+1;

    End;

    B[i]:=k;

    WriteLn;

    End;

    WriteLn;

    For i: = 1 to N do

    Write (B[i],' ')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу формирования и вывода на экран одномерного массива, состоящего из количества положительных элементов строк двумерного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Помогите решить. Составьте программу формирования и вывода на экран одномерного массива, состоящего из элементов главной диагонали двумерного массива, заданного с помощью датчика случайных чисел. (Паскаль абс) С объяснением.
Ответы (1)
1) напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел. замените в нем все четные значения элементов суммой индексов элементов главной диагонали.
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1) напишите программу формирования массива размером 5 х5 с помощью датчика случайных чисел. найдите максимальное значение элементов и замените последний элемент каждой строки этим значением.
Ответы (1)