Задать вопрос
24 декабря, 11:46

Составьте программу нахождения среднего арифметического всех элементов матрицы в размере 8*8

+5
Ответы (1)
  1. 24 декабря, 13:22
    0
    Выше решение не для матрицы 8 х8, а для одномерного массива из 5-ти элементов. Вот для двухмерной матрицы 8 х8:

    const n=8;

    var a:array[1 ... n, 1 ... n] of integer;

    i, j, s:integer; sr:real;

    begin

    for i:=1 to n do

    for j:=1 to n do a[i, j]:=random (50) - 20;

    for i:=1 to n do begin

    for j:=1 to n do write (a[i, j]:4) ;

    writeln;

    end;

    writeln;

    sr:=0; s:=0;

    for i:=1 to n do

    for j:=1 to n do

    s:=s+a[i, j];

    sr:=s/sqr (n) ;

    write ('среднее арифметическое всех элементов матрицы = ', sr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу нахождения среднего арифметического всех элементов матрицы в размере 8*8 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
С++. Дана целая матрица А (N, M). Составить программу подсчета среднего арифметического значения матрицы. Найти отклонение от среднего у элементов каждой строки.
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)
Задан одномерный массив Z (N) (N
Ответы (1)
Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc
Ответы (1)