Задать вопрос
15 июня, 03:19

1) Определите значение переменных a и b после выполнения фрагмента алгоритма:

a: = 86;

b: = a mod 10 + 14;

a: = а div 3 * 5;

2) Определите значение переменных a и b после выполнения фрагмента алгоритма:

a: = 8673;

b: = (a mod 100) * 10 + 14;

a: = (а div 100) * 100;

3) Составить алгоритм, в котором меньшее из двух данных чисел заменяется суммой этих чисел.

+1
Ответы (1)
  1. 15 июня, 06:14
    0
    1.

    a = 86

    b = a mod 10 + 14 = 86 mod 10 + 14 = 6+14 = 20

    a = а div 3 * 5 = 86 div 3 * 5 = 28*5 = 140

    Ответ: a=140, b=20

    2.

    a = 8673

    b = (a mod 100) * 10 + 14 = (8673 mod 100) * 10 + 14 = 73*10+14 = 730+14=744

    a = (а div 100) * 100 = (8673 div 100) * 100 = 86*100 = 8600

    Ответ: a=8600, b=744

    3.

    var a, b:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    if a
    writeln ('a=', a,' b=', b) ;

    end.

    Пример:

    a=15

    b=27

    a=42 b=27
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Определите значение переменных a и b после выполнения фрагмента алгоритма: a: = 86; b: = a mod 10 + 14; a: = а div 3 * 5; 2) Определите ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы