Задать вопрос
14 мая, 09:46

Ребят, помогите!

написать программу:

Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах десятков тысяч, сотен и единиц (1 234 567) числом четным или кратным 7?

+1
Ответы (1)
  1. 14 мая, 11:25
    0
    var

    s, x, n: integer;

    begin

    writeln ('Введите число: ') ;

    read (n) ;

    x : = 1000000;

    repeat

    s : = s + (n div x) mod 10;

    x : = trunc (x / 10) ;

    until x < 1;

    writeln ('Сумма = ', s) ;

    if s 0 then

    begin

    if s mod 2 = 0 then writeln ('Сумма - число четное')

    else writeln ('Сумма - число нечетное') ;

    if s mod 7 = 0 then writeln ('Сумма - число кратное 7')

    else writeln ('Сумма - число не кратное 7') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, помогите! написать программу: Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах десятков тысяч, сотен и единиц ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах миллионов, сотен и десятков (1 234 567) числом, кратным 3 или 9?
Ответы (1)
Является ли сумма цифр заданного 4-значного числа, стоящих в разрядах сотен и десятков (например, 4 567) числом, кратным 3 или 2?
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах?"
Ответы (1)