Задать вопрос
24 августа, 10:05

Является ли сумма цифр заданного 4-значного числа, стоящих в разрядах сотен и десятков (например, 4 567) числом, кратным 3 или 2?

+5
Ответы (1)
  1. 24 августа, 10:52
    0
    Var n, one, dec, hun, s: integer;

    begin

    writeln (' введи четырехзначное число') ;

    readln (n) ;

    one: = n mod 10; (находим цифру на месте единиц)

    dec: = (n div 10) mod 10; на предпоследнем разряде

    hun: = (n div 100) mod 10; на третьем разряде с конца

    t: = n div 1000; на первом разряде

    s:=one+dec+hun+t;

    if (s mod 2=0) or (s mod 3=0) then writeln (' кратна 2 или 3) else writeln (' не кратна') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Является ли сумма цифр заданного 4-значного числа, стоящих в разрядах сотен и десятков (например, 4 567) числом, кратным 3 или 2? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ребят, помогите! написать программу: Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах десятков тысяч, сотен и единиц (1 234 567) числом четным или кратным 7?
Ответы (1)
Является ли сумма цифр заданного 7-значного числа, стоящих в разрядах миллионов, сотен и десятков (1 234 567) числом, кратным 3 или 9?
Ответы (1)
Алина задумала четырехзначное число из цифр 1,2,3,4. У задуманного числа и числа 1243 одинаковая цифра стоит в двух разрядах, а у задуманного числа и у числа 2143 одинаковых цифр в совпадающих разрядах нет.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
составить программу вычисления суммы цифр введенного с клавиатуры 3 - х значного натурального числа. Например для числа 128 сумма цифр 11, а для числа 345 сумма цифр12.
Ответы (2)