Задать вопрос
14 мая, 08:50

Написать программу, считающую сумму цифр целого числа. программа должна быть написана в TP (Turbo Pascal)

+5
Ответы (1)
  1. 14 мая, 09:56
    0
    program z1;

    var S, n:integer;

    begin

    writeln ('Введите число') ;

    readln (n) ;

    while n>0 do begin

    S:=S+n mod 10;

    n:=n div 10;

    end;

    writeln ('S=', S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, считающую сумму цифр целого числа. программа должна быть написана в TP (Turbo Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Написать программу, выдающую результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода. (неверный вод-если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) Делать в Turbo Pascal
Ответы (2)
Написать программу для рассчета стоимости покупки из 5 предметов, если цена каждого из предметов задается командой ввода. Программа должна быть понятна любому пользователю. turbo pascal
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)