Задать вопрос
9 сентября, 04:04

Написать программу, выдающую результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода. (неверный вод-если сумма не равна 10 то программа должна заново спросить какие числа он хочет ввести) Делать в Turbo Pascal

+1
Ответы (2)
  1. 9 сентября, 05:40
    0
    function sum (n : integer) : integer;

    begin

    sum : = 0;

    while n > 0 do

    begin

    sum : = sum + n mod 10;

    n : = n div 10;

    end;

    end;

    var

    a : integer;

    begin

    repeat

    writeln ('a = ') ;

    read (a) ;

    until sum (a) = 10;

    writeln ('OK') ;

    end.
  2. 9 сентября, 07:03
    0
    var

    a, a1, a2:integer;

    begin

    repeat

    writeln (' Введите число') ;

    readln (a) ;

    a1:=a div 10;

    a2:=a mod 10;

    until (a1+a2=10) ;

    writeln ('Верно ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, выдающую результат - равна ли сумма цифр введенного положительного числа 10 с защитой от неверного ввода. (неверный ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
Написать программу для рассчета стоимости покупки из 5 предметов, если цена каждого из предметов задается командой ввода. Программа должна быть понятна любому пользователю. turbo pascal
Ответы (1)
Pascal ABC Напишите программу, которая определяет количество элементов, сумма цифр которых четна. Формат ввода Программа получает на вход последовательность целых чисел, заканчивающаяся нулем (0 - признак окончания ввода).
Ответы (1)