Задать вопрос
6 марта, 15:09

Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах?"

+3
Ответы (1)
  1. 6 марта, 17:47
    0
    Var a, s1, s2:integer;

    begin

    read (a) ;

    if (a>=1000) and (a<=9999) then

    begin

    s1: = (a mod 10) + ((a mod 1000) div 100) ;

    s2: = (a div 1000) + ((a mod 100) div 10) ;

    if (s1>s2) then writeln ('Сумма цифр, стоящих на четных местах больше суммы цифр, стоящих на нечетных местах') ;

    if (s1
    if (s1=s2) then writeln ('Сумма цифр, стоящих на четных местах равна сумме цифр, стоящих на нечетных местах') ;

    end

    else writeln ('Вы ввели не 4-ёхзначное число') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Написать программу на языке Паскаль. 1. Написать программу из 3 введенных значений. Найти максимальное 2. Написать программу запрашивающую номер класса и выводящееся сообщения если 1-4 класса-младшая школа, 5-9-средняя, 10-11-старшая 3.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
1. написать программу, производящее "неформатный" вывод разных значений 2. написать программу, производящее "форматный" вывод разных значений 3. написать программу использующие процедуру writeln c параметрами и без параметров
Ответы (1)
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)