Задать вопрос
2 августа, 13:56

Написать программу для решения уравнения AX2 + BX+C=0.

(Дописать до конца)

2) Написать программу для решения неравенства Bx+C<0.

3) Написать программу для решения уравнения

+ = 0

+2
Ответы (1)
  1. 2 августа, 17:27
    0
    1.

    program z1;

    var a, b, c, x1, x2:real;

    begin

    writeln ('введите коэффициенты А (отличное от нуля), В и С ') ;

    readln (a, b, c) ;

    if sqrt (b*b-4*a*c) >0 then

    begin

    x1: = (-b+sqrt (b*b-4*a*c)) / 2/a;

    x2: = (-b-sqrt (b*b-4*a*c)) / 2/a;

    writeln ('x1=', x1,', x2=', x2) ;

    end

    else if sqrt (b*b-4*a*c) = 0 then

    begin

    x1: = (-b+sqrt (b*b-4*a*c)) / 2/a;

    writeln ('x=', x1)

    end

    else writeln ('уравнение не имеет корней') ;

    end.

    2.

    program z1;

    var b, c, x:real;

    begin

    writeln ('введите коэффициенты B (отличное от нуля) и С ') ;

    readln (b, c) ;

    x:=-c/b;

    writeln ('x<', x) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы