Задать вопрос
2 апреля, 04:38

Дано уравнение ax2+bx+c=0 найти решение этого уравнения или сообщить, что решения не существует

+3
Ответы (2)
  1. 2 апреля, 04:55
    0
    √D=b2-4ac

    x1=-b+√D/2a

    x2 = b+√D/2a
  2. 2 апреля, 06:52
    0
    Var

    a, b, c, d:double;

    Begin

    write ('a = ') ;

    read (a) ;

    write ('b = ') ;

    read (b) ;

    write ('c = ') ;

    read (c) ;

    d:=sqrt (b*b-4*a*c) ;

    if d > 0 then begin

    writeln ('x1 = ', (-b+d) / (2*a)) ;

    writeln ('x2 = ', (-b-d) / (2*a)) ;

    end

    else

    if d = 0 then

    writeln ('x = ', - b / (2*a))

    else

    write ('Решений нет') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано уравнение ax2+bx+c=0 найти решение этого уравнения или сообщить, что решения не существует ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано уравнение ax+b=0. Найти решение этого уравнения или сообщить, что решения не существует.
Ответы (1)
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Злоумышленник поменял местами действия в алгоритме вычисления среднего арифметического из квадратного корня трёх чисел: Присвоить а значение (а2+в2+с2) / 3. Вести а, в, с Сообщить "Среднее арифметическое квадратов равно" Сообщить а.
Ответы (1)
Написать в программе Паскаль: Дано целое число. Если оно положительное и трехзначное, найти сумму первой и третьей цифры этого числа, в противном случае сообщить, что число нам не подходит.
Ответы (1)