Задать вопрос
1 ноября, 16:47

Составить программу с ветвящейся структурой, используя условный оператор if для квадратного уравнения вида ax2+bx+c=0

+2
Ответы (2)
  1. 1 ноября, 17:59
    0
    Var a, b, c, d:real;

    begin

    readln (a, b, c) ;

    d:=sqr (b) - 4*a*c;

    if d<0 then writeln ('Net kornei') ;

    if d=0 then writeln ('x=',-b / (2*a)) ;

    if d>0 then writeln ('x1=', (-b-sqrt (d)) / (2*a),' x2=', (-b+sqrt (d)) / (2*a)) ;

    end.
  2. 1 ноября, 18:46
    0
    Var a, b, c, x, x1, x2:real;

    begin

    writeln (' ... ') ;

    readln (a, b, c) ;

    d:=b*b-4*a*c;

    if d<0 then writeln ('корней нет') ;

    if d=0 then x:=-b/2/a;

    if d>0 then;

    begin;

    x1=: (-b+sqrt (d)) / 2/a;

    x2: = (-2-sqrt (d)) / 2/a;

    writeln ('x1=', x1:10:2) ;

    writeln ('x2=', x2:10:2) ;

    end;

    end
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу с ветвящейся структурой, используя условный оператор if для квадратного уравнения вида ax2+bx+c=0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
Ответить на следующие вопросы: 1) Что означает фраза: "задачи с ветвлением"? 2) Как записывается полный условный оператор? 3) Как записывается неполный условный оператор? 4) Какие математические действия можно выполнять в задачах с ветвлением?
Ответы (1)
В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)
Ответы (1)
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
Линейные алгоритмы. 1. Даны три действительных положительных числа. Найти среднее геометрическое и среднее арифметическое этих чисел. Условный оператор if. 2. Заданы два числа х, у. Меньшее из двух значений заменить на 0.
Ответы (1)