Задать вопрос
3 января, 11:01

В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)

+3
Ответы (1)
  1. 3 января, 12:13
    0
    Var a, b, c, x1, x2, D:real;

    begin

    writeln ('Введите значение a, b и c') ;

    readln (a, b, c) ;

    D:=sqr (b) - 4*a*c;

    if D>0 then

    begin

    x1: = (-b+sqrt (D)) / 2*a;

    x2: = (-b-sqrt (D)) / 2*a;

    writeln ('x1 = ', x1, ' x2 = ', x2) end

    else

    writeln ('Корней нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Соотнесите названия операторов, служебных слов, функций и их написание на языке Paskal: 1. Оператор ввода данных a) Begin, End 2. Условный оператор в неполной форме b) Sqrt (X) 3. Оператор цикла с предусловием c) N div M 4.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Ответить на следующие вопросы: 1) Что означает фраза: "задачи с ветвлением"? 2) Как записывается полный условный оператор? 3) Как записывается неполный условный оператор? 4) Какие математические действия можно выполнять в задачах с ветвлением?
Ответы (1)