Задать вопрос
22 июля, 01:52

Написать в паскаль ABC

1) напишите программу, перемножающую целые числа без использования операции <>. например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m + ... + m).

2) Напишите программу возведения числа в целую степень. Число и степень запрашивайте у пользователя.

+4
Ответы (2)
  1. 22 июля, 04:35
    0
    Опишу только момент, в котором вся суть, т. е. без ввода данных и т. д.:

    ...

    for i:=1 to (на сколько надо умножить) do

    k:=k+a {k-итоговая сумма, перед циклом к=0, в конце к0; a-вводимое число}

    ...

    таким же образом поступаем и с умножением
  2. 22 июля, 05:00
    0
    Uses crt;

    var x, y, pr, i:integer;

    begin

    pr:=0;

    write ('1 множитель:') ; readln (x) ;

    write ('2 множитель:') ; readln (y) ;

    for i:=1 to x do

    pr:=pr+y;

    writeln ('произведение:', pr) ;

    end.

    ---

    uses crt;

    var x, y, st, i:integer;

    begin

    st:=1;

    write ('число:') ; readln (y) ;

    write ('степень:') ; readln (x) ;

    for i:=1 to x do

    st:=st*y;

    writeln ('результат::', st) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать в паскаль ABC 1) напишите программу, перемножающую целые числа без использования операции . например, при умножении целых чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, перемножающую целые числа без использования операции "*". Например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m+ ...+m). На языке Паскаль.
Ответы (1)
Написать программу перемножающую целые числа без использования операции "*". паскаль абс
Ответы (2)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
1) Разработайте программу, запрашивающую у пользователя длины обеих катетов прямоугольного треугольника, и выводящую на экран гипотезу по формуле Пифагора 2) Запросите у пользователя длину ребра куба, Найдите и выведите на экран площадь одной грани,
Ответы (1)
За 8 класс Решите задачу: Напишите программу, вычисляющую и выводящую на экран число бит, если задано число Мбайт. Количество Мбайт запрашивайте у пользователя программы.
Ответы (1)