Задать вопрос
13 августа, 09:45

Напишите программу, перемножающую целые числа без использования операции "*". Например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m+ ...+m). На языке Паскаль.

+3
Ответы (1)
  1. 13 августа, 13:13
    +1
    Var m, n, i:integer;

    begin

    writeln ('введите число ') ;

    readln (n) ;

    writeln ('на что умножить? ') ;

    readln (m) ;

    for i:=1 to m-1 do n:=n+n;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, перемножающую целые числа без использования операции "*". Например, при умножении целых чисел n*m число m надо сложить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать в паскаль ABC 1) напишите программу, перемножающую целые числа без использования операции . например, при умножении целых чисел n*m число m надо сложить само с собой n раз (m+m + ... + m).
Ответы (2)
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Написать программу перемножающую целые числа без использования операции "*". паскаль абс
Ответы (2)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)