Задать вопрос
29 января, 15:38

Изветсны оценки по информатике 15 студентов группы. Сформировать случайным образом оценки из диапазона [2; 5], вывести их на экран. Определить общую успеваемость группы по предемету

Общая_успеваемость = Количество_студентов - Количество_"2"/Количество_студентов * 100%

+3
Ответы (1)
  1. 29 января, 16:20
    0
    Var

    i, count: integer;

    a: array [1 ... 15] of integer;

    begin

    randomize () ;

    for i:=1 to 15 do

    begin

    a[i]: = 2 + random (4) ;

    if a[i] = 2 then count: = count + 1;

    end;

    for i:=1 to 15 do write (a[i], ' ') ;

    Writeln;

    Writeln ('Общая успеваемость = ', (15-count) * 100/15:0:3, '%') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Изветсны оценки по информатике 15 студентов группы. Сформировать случайным образом оценки из диапазона [2; 5], вывести их на экран. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Сформировать матрицу размером 5*8 случайным образом из диапазона значений 0-10. вывести ее на экран и определить количество элементов больших пяти в третьем столбце и их сумм если таких элементов нет то указать что они отсутствуют
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. Массив из 25 элементов заполнить случайными числами из диапазона [-100 ... 100] и вывести на экран. Найдите элемент массива с максимальной суммой цифр. 2. Массив из 20 элементов заполнить случайными числами из диапазона [1 ...
Ответы (1)