Задать вопрос
18 июня, 18:36

Сформировать матрицу размером 5*8 случайным образом из диапазона значений 0-10. вывести ее на экран и определить количество элементов больших пяти в третьем столбце и их сумм если таких элементов нет то указать что они отсутствуют

+2
Ответы (1)
  1. 18 июня, 21:46
    0
    Var a=array [1 ... 5,1 ... 8]of byte;

    i, j, sum:integer;

    begin

    for i:=1 to 5 do

    for j:=1 to 8 do

    a[i, j]:=random (10) ;

    for i:=1 to 5 do

    begin

    for j:=1 to 8 do

    write (" ", a[i, j]) ;

    writeln () ;

    end;

    sum:=0;

    for i:=1 to 5 do

    for j:=1 to 8 do

    if (a[i, j]>5) then sum:=sum+a[i, j];

    if (sum0) then writeln ("summa = ", sum) else if (sum=0) then writeln ("net bolhe 5") ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать матрицу размером 5*8 случайным образом из диапазона значений 0-10. вывести ее на экран и определить количество элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Помогите, не могу понять, как повернуть матрицу на 90 градус. Сформировать матрицу 4*4, рандомно заполнить, вывести исходную матрицу, а затем повернуть её на 90 градусов и снова вывести. на языке Pascal
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
1. Массив из 25 элементов заполнить случайными числами из диапазона [-100 ... 100] и вывести на экран. Найдите элемент массива с максимальной суммой цифр. 2. Массив из 20 элементов заполнить случайными числами из диапазона [1 ...
Ответы (1)