Задать вопрос
8 февраля, 23:22

Составьте программу вычисления в одномерном массиве минимального элемента и его номера.

+4
Ответы (2)
  1. 8 февраля, 23:34
    0
    Uses crt;

    const N=10;

    var a:array [1 ... N] of integer;

    x, y, min:integer;

    begin

    for x:=1 to N do

    begin

    write ('a[', x,']:') ;

    readln (a[x]) ;

    end;

    min:=a[1];

    y:=1;

    for x:=1 to N do

    if a[x]
    begin

    min:=a[x];

    y:=x;

    end;

    writeln ('min[', y,']:', min) ;

    end.
  2. 9 февраля, 02:53
    0
    1)

    var

    a: array [1 ... 100] of longint;

    i, j, k, n:longint;

    begin

    readln (n) ;

    for i:=1 to n do readln (a[i]) ;

    k:=a[1]; j:=1;

    for i:=1 to n do

    if a[i]
    writeln (k, ' ', j) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления в одномерном массиве минимального элемента и его номера. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
Составьте программу вычисления в массиве B (N) минимального элемента и его номера
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)