Задать вопрос
2 ноября, 06:34

В школе продолжительность каждого урока 45 минут, а

перемены между уроками - всего 5 минут. Первый урок начинается ровно в 8 часов

утра. Напишите программу, отвечающую на вопрос "во сколько в этой школе

заканчивается K-ый урок?"

+5
Ответы (1)
  1. 2 ноября, 08:12
    0
    uses crt;

    var h, m, k:integer;

    begin

    readln (k) ;

    m: = (45*k) + (5 * (k-2)) ;

    h:=8 + (m div 60) ;

    m:=m mod 60;

    write (h,':', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В школе продолжительность каждого урока 45 минут, а перемены между уроками - всего 5 минут. Первый урок начинается ровно в 8 часов утра. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В некоторой школе занятия начинаются в 9:00. Продолжительность урока - 45 минут, после 1-го, 3-го, 5-го и т. д. уроков перемена 5 минут, а после 2-го, 4-го, 6-го и т. д. - 15 минут. Дан номер урока (число от 1 до 10).
Ответы (1)
Расписание звонков. В школе задается начало учебного дня (8-30), продолжительность урока (45 мин), продолжительность обычного (5 мин) и большого (15 мин после третьего урока) перерьшов, количество уроков (6).
Ответы (1)
1. Написать программу, задающую вопрос: "Сколько байт в килобайте?" и отвечающую: "Вы правы" или "Вы ошиблись", в зависимости от ответа. Pascal Abc
Ответы (1)
Составьте программу к следующей задаче: Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2 часов и min2 минут.
Ответы (1)
Продолжительность занятия - 90 минут, после 1-го, 2-го занятия перемены по 10 минут, а после 3-го - 40 минут. Дан номер занятия (число от 1 до 6). Определите, когда заканчивается занятие.
Ответы (1)