Задать вопрос
13 марта, 20:01

В некоторой школе занятия начинаются в 9:00. Продолжительность урока -

45 минут, после 1-го, 3-го, 5-го и т. д. уроков перемена 5 минут, а

после 2-го, 4-го, 6-го и т. д. - 15 минут.

Дан номер урока (число от 1 до 10). Определите, когда

заканчивается указанный урок. Выведите два целых числа: время окончания

урока в часах и минутах. При решении этой задачи нельзя пользоваться

циклами и условными инструкциями. Напишите что нужно сделать (pascal)

+3
Ответы (1)
  1. 13 марта, 21:44
    0
    Считаем, сколько пройдёт минут после 2N+1 урока:

    (2N + 1) * 45 - число минут собственно на учёбу

    N * 15 - число минут на длинные перерывы

    N * 5 - число минут на короткие перерывы

    Считаем, сколько пройдёт минут после 2N уроков:

    2N*45 - число минут собственно на учёбу

    (N - 1) * 15 - число минут на длинные перерывы

    N * 5 - число минут на короткие перерывы

    В общем случае, после M уроков (сравниваем ответы) :

    M*45 - число минут собственно на учёбу

    (M div 2 - (M+1) mod 2) * 15 - число минут на длинные перерывы

    (M div 2) * 5 - число минут на короткие перерывы

    Т. о., время T (в минутах) можно найти по формуле:

    T = M*45 + (M div 2 - (M+1) mod 2) * 15 + (M div 2) * 5

    Если нужно привести к формату H:M, то

    H = 9 + (T div 60)

    M = T mod 60
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В некоторой школе занятия начинаются в 9:00. Продолжительность урока - 45 минут, после 1-го, 3-го, 5-го и т. д. уроков перемена 5 минут, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Урок в школе длится 40 минут, перемена 10 минут. Сколько времени проведет ученик в школе, если у него N уроков и 45 минут он будет заниматься танцами. Ответ дать в часах и минутах. программа
Ответы (2)
Данны сторны прямоугольника найти его периметр пример как делать дано время в чесах и в минутах выразить его в минутах var C, A, B:inter; begin writeln ('Введите время в часах и в минутах') ; readln; C:=A*60+B; writeln (' время в минутах') ; readln;
Ответы (1)
Продолжительность занятия - 90 минут, после 1-го, 2-го занятия перемены по 10 минут, а после 3-го - 40 минут. Дан номер занятия (число от 1 до 6). Определите, когда заканчивается занятие.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
В школе продолжительность каждого урока 45 минут, а перемены между уроками - всего 5 минут. Первый урок начинается ровно в 8 часов утра. Напишите программу, отвечающую на вопрос "во сколько в этой школе заканчивается K-ый урок?"
Ответы (1)