Задать вопрос
23 октября, 09:25

Составьте программу к следующей задаче:

Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 часов и min1 минут, а закончил, когда было h2 часов и min2 минут. Составьте программу, позволяющую определить, сколько времени (в часах и минутах) ученик решал эти задачи.

+3
Ответы (1)
  1. 23 октября, 11:48
    0
    Используется время одних суток.

    var h1, min1, h2, min2, h, min, m:integer;

    begin

    write ('h1, m1: ') ;

    readln (h1, min1) ;

    write ('h2, m2: ') ;

    readln (h2, min2) ;

    m: = (h2*60+min2) - (h1*60+min1) ;

    h:=m div 60;

    min:=m mod 60;

    writeln ('h = ', h,' min = ', min) ;

    end.

    Пример:

    h1, m1: 1 20

    h2, m2: 3 15

    h = 1 min = 55
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу к следующей задаче: Ученик начал решать задачи данного урока программирования, когда электронные часы показывали h1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Данны сторны прямоугольника найти его периметр пример как делать дано время в чесах и в минутах выразить его в минутах var C, A, B:inter; begin writeln ('Введите время в часах и в минутах') ; readln; C:=A*60+B; writeln (' время в минутах') ; readln;
Ответы (1)
Бабы-Яги есть песочные часы на 7 минут и 24 минут и книга колдовских рецептов, в которой разные зелья варятся разное время.
Ответы (1)
В некоторой школе занятия начинаются в 9:00. Продолжительность урока - 45 минут, после 1-го, 3-го, 5-го и т. д. уроков перемена 5 минут, а после 2-го, 4-го, 6-го и т. д. - 15 минут. Дан номер урока (число от 1 до 10).
Ответы (1)
2 задачи по программированию: 1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого
Ответы (1)