Задать вопрос
31 мая, 07:11

2 задачи по программированию:

1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z = (signX + signY) * sign (X+Y), определив и используя функцию: Sign (a) = 0 при a=0

Sign (a) = - 1 при a<0

Sign (a) = 1 при a>0.

+2
Ответы (1)
  1. 31 мая, 08:59
    0
    Program cgt;

    var x1, y1, x2, a, y2, b, c, x3, y3:real;

    procedure IOI (x1, y1, x2, y2:real; var a:real) ;

    begin

    a:=sqrt ((x1-x2) * (x1-x2) + (y1-y2) * (y1-y2)) ;

    end;

    begin

    read (x1, x2, y1, y2, x3, y3) ;

    IOI (x1, y1, x2, y2, a) ;

    IOI (x1, y1, x3, y3, b) ;

    IOI (x3, y3, x2, y2, c) ;

    if (a>=b) and (a>=c) then writeln ('первая и вторая точка ', a) else

    if (b>=a) and (b>=c) then writeln ('первая и третая точка ', b) else

    if (c>=b) and (c>=a) then writeln ('третая и вторая точка ', c) ;

    end.

    2)

    program cgt;

    var z, x, y:real; function IOI (x:real) : real;

    begin

    if (x=0) then IOI:=0;

    if (x<0) then IOI:=-1;

    if (x>0) then IOI:=1;

    end;

    begin

    read (x, y) ;

    z: = (IOI (x) + IOI (Y)) * IOI (x+y) ;

    writeln (z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2 задачи по программированию: 1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи по паскалю 1. Вычислить z (x) = sign (x) + sign (y) * sign (x+y) Используя функцию sign (x) = - 1 если x0 2. Написать процедуру для нахождения степени числа и вычислить значение выражения:x^5+x^4+x^8 3.
Ответы (1)
В математике функция sign (x) (знак числа) определена так: sign (x) = 1, если x > 0, sign (x) = - 1, если x < 0, sign (x) = 0, если x = 0. Для данного числа x выведите значение sign (x). Ввод 179 Вывод 1
Ответы (1)
Понятие инкапсуляция, наследование, полиморфизм относятся к ... А) структурному программированию б) логическому программированию в) объектно-ориентированному программированию г) обозначение элементов на блок-схемах
Ответы (1)
1. Дан массив из 20 чисел. В массиве найти и вывести на печать минимальные и максимальные элементы. 2. Даны три числа. Оформить в виде функции вычисление среднеарифметического, вычисление суммы и произведения этих чисел
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)